微信机器人制作可爱猫插件实战编写教程源码

陌路 2019-09-22 17:33:48
导读原理和流程讲解,第二节是直接实战教程,课程源码和主程序及开发包,一起学习,共同一起进步吧。

微信机器人制作可爱猫插件实战编写教程源码

应用.Name = “可爱猫插件例子4.1” ' 插件名字
应用.Author = “winn” ' 插件作者
应用.Desc = “这里是插件的介绍,有问题可以联系作者”
应用.Version = “1.0.1” ' 自定义的版本号
应用.Img = #插件封面例子2 ' 建议 50 * 50 像素,可自己替换,推荐修改图片尺寸
应用.MenuButtonTitle = “面板” ' 点击菜单时,按钮的标题
应用.AuthorKey = “888888888” ' 暂未启用,随便填
' 以上插件信息,请不要随意删除
返回 (M.初始化 (应用, lApiString)) ' 固定返回


配置目录 = 指针到文本 (path) ' 参考:F:\可爱猫\app\demo.cat\
M.开启错误捕获 () ' 建议开启,插件出错时,可以立即暂停插件且不关闭可爱猫的运行,并在日志显示
M.添加日志 (“插件例子消息 | 软件启动,插件准备初始化,插件配置路径:” + 配置目录)
返回 (#返回_忽略)

.如果真 (json.解析 (json_msg))
是否即时到账 = 选择 (json.取通用属性 (“is_arrived”) = “1”, 真, 假) ' 这个变量用来判断这一笔转账是否是正常的,因为有可能是延迟转账类型
是否已经收款 = 选择 (json.取通用属性 (“is_received”) = “1”, 真, 假) ' 这个变量用来判断是否收款成功,因为本事件有(收到转账消息、同意收款后的消息、转账过期的消息)这几种类型,这里代表已经收到了
接收方订单号 = json.取通用属性 (“robot_pay_id”)
发送方订单号 = json.取通用属性 (“from_pay_id”)
转账备注 = json.取通用属性 (“remark”)
.如果真结束
M.添加日志 (“插件例子消息 | 收到转账消息,用户昵称:” + robot_wxid + “ ” + from_wxid + “ 转账金额:” + 到文本 (money) + “ json:” + json_msg)
.如果真 (robot_wxid ≠ from_wxid)
M.接收好友转账 (robot_wxid, from_wxid, json_msg)
.如果真结束
.如果真 (是否已经收款)
M.添加日志 (“插件例子消息 | 已经收款:” + money + “元”)
.如果真结束
返回 (#返回_忽略)