游戏脚本大漠插件找人物坐标视频教程

陌路 2019-10-06 14:40:59
导读网络游戏脚本大漠插件找人物坐标视频学习教程自动取人物是还有疲劳,没疲劳自动更换角色,没疲劳自动更换角色2 继续格蓝迪,2次格蓝迪 1次别的图。

游戏脚本大漠插件找人物坐标视频教程

1 打开菜单 游戏设置 系统 往下拉 到最后 角色名称信息设置 悬着C类 保存
基础篇

1、取人物坐标,

2、取怪物坐标,

3、取当前HP

4、取当前MP

5、取地面上物品坐标

初级篇

1,计算角色移动速度

2. 角色移动到怪物

3. 角色移动到物品

4. 优化角色移动 取最近的距离

5. 自动加HP 自动 加MP

5.5自动打怪

5.6自动捡物品

6. 自动过图

7. BOOS房间处理

7.自动出售物品

' 我用的魔鬼作坊模块 不懂基础的 去看教程
线程_创建线程 (&循环子程序)

.子程序 __启动窗口_创建完毕

dm.初始_注册大漠插件 ()
dm.初始_创建大漠多线程 ()
dm.基本_设置全局路径 (, 取运行目录 ())

.子程序 取人物坐标
.局部变量 x, 整数型
.局部变量 y, 整数型

dm.图色_找图 (, 0, 0, 1000, 1000, 取运行目录 () + “\图片加载\人物坐标标识.bmp”, “”, 1, 0, x, y)
x = x + 20
y = y + 120
标签1.标题 = “人物坐标x:” + 到文本 (x)
标签2.标题 = “人物坐标y:” + 到文本 (y)