学校智能排课系统源码课程表制作工具

陌路 2019-11-04 20:28:07
导读学校智能排课系统源码本软件用于学校辅助排课可以排总课程表和各班课程表,最后在桌面生成总课程表和各班课程表文件格式为excel表格。

学校智能排课系统源码课程表制作工具

操作无需流程,可以边排课边增加班级、课程、教师等,甚至可以边排课边改变班级、教师、课程等的名称或删除它们,改变工作日以及每天上课节数,改变课务安排等,所有这些软件都将 自动 处理相关数据及当前的课表,您尽管放心操作就是。

综合信息 = 分割文本 (列表框1.取项目文本 (列表框行次 - 1), “-”, )
.如果真 (Excel工作簿1.内容 = 综合信息 [1]) ' 判断班级
.如果真 (综合信息 [2] = “数学” 或 综合信息 [2] = “英语” 或 综合信息 [2] = “语文”) ' 写每天的第2节
.如果 (周次 < 5)
Excel工作簿1.首单元格 = 字符 (67 + (周次 - 1) × 6) + 到文本 (分课到何班 + 1)
Excel工作簿1.尾单元格 = 字符 (67 + (周次 - 1) × 6) + 到文本 (分课到何班 + 1)
单元格位置数据 = Excel工作簿1.内容
.否则
Excel工作簿1.首单元格 = “AA” + 到文本 (分课到何班 + 1)
Excel工作簿1.尾单元格 = “AA” + 到文本 (分课到何班 + 1)
单元格位置数据 = Excel工作簿1.内容
.如果结束
.如果真 (综合信息 [2] ≠ 取文本左边 (单元格位置数据, 4)) ' 避免和同头班课程重复
Excel工作簿1.首单元格 = 字符 (66 + (周次 - 1) × 6) + 到文本 (分课到何班 + 2)
Excel工作簿1.尾单元格 = 字符 (66 + (周次 - 1) × 6) + 到文本 (分课到何班 + 2)
.如果 (周次 < 5)
Excel工作簿1.首单元格 = 字符 (66 + (周次 - 1) × 6) + 到文本 (分课到何班 + 2)
Excel工作簿1.尾单元格 = 字符 (66 + (周次 - 1) × 6) + 到文本 (分课到何班 + 2)
单元格位置数据 = Excel工作簿1.内容
.否则
Excel工作簿1.首单元格 = “Z” + 到文本 (分课到何班 + 2)
Excel工作簿1.尾单元格 = “Z” + 到文本 (分课到何班 + 2)
单元格位置数据 = Excel工作簿1.内容
.如果结束
.如果真 (综合信息 [2] ≠ 取文本左边 (单元格位置数据, 4)) ' 避免同一个班课程重复
.如果 (67 + (周次 - 1) × 6 ≤ 取代码 (“Z”, ))
Excel工作簿1.首单元格 = 字符 (67 + (周次 - 1) × 6) + 到文本 (分课到何班 + 2)
Excel工作簿1.尾单元格 = 字符 (67 + (周次 - 1) × 6) + 到文本 (分课到何班 + 2)
Excel工作簿1.内容 = 综合信息 [2] + 综合信息 [3]
列表框1.删除项目 (列表框行次 - 1)
跳出循环 ()
.否则
Excel工作簿1.首单元格 = “A” + 字符 (65 + 节次) + 到文本 (分课到何班 + 2)
Excel工作簿1.尾单元格 = “A” + 字符 (65 + 节次) + 到文本 (分课到何班 + 2)
Excel工作簿1.内容 = 综合信息 [2] + 综合信息 [3]
列表框1.删除项目 (列表框行次 - 1)
跳出循环 ()

排课就是在一组现实的课表上拖拉,软件用不同颜色提示拖到不同位置对课表的影响,只用看着颜色拖,就可以排出优秀的课表了;

简洁直 观的规则,很容 易表达如:副科不可在一二节上,最好在除星期一外的上午第四节课上课等复杂的规则;

并行的操作模式,可以同时操作多个班级的课表,并显示多个教师的课表,很容易相互切换,数据的改变都将自动 同步;

软件能适应的学校规模无限制(无限的班级),同年级班级数无限制;教师数量以及课程数量都没有限制,只要你硬件的性能够强大;