易语言文本加密E4A/RC4加密法

陌路 2019-10-17 18:22:25
导读这个是易安卓的RC4加密方案稍微把dLL转成了程序集源码这个是易安卓的RC4加密方案稍微把dLL转成了程序集。

易语言文本加密E4A/RC4加密法

.子程序 加密, 文本型, 公开, 用于将文本加密成为E4A样式的RC4密文
.参数 欲加密的文本, 文本型, , 提供需要加密的文本,如提供空文本将直接返回空文本。
.参数 用于加密的密码, 文本型, , 提供用于加密的密码,提供空密码将直接返回原文本。

.如果真 (欲加密的文本 = “”)
    返回 (“”)
.如果真结束
.如果真 (用于加密的密码 = “”)
    返回 (欲加密的文本)
.如果真结束
返回 (字节集转换到十六进制文本 (RC4加解密_E4A (到字节集 (欲加密的文本), 用于加密的密码)))

.子程序 解密, 文本型, 公开, 用于将E4A样式的RC4密文解密。
.参数 欲解密的文本, 文本型, , 提供需要解密的文本,如提供空文本将直接返回空文本。
.参数 用于解密的密码, 文本型, , 提供用于用于解密的密码,提供空密码将直接返回原文本。

.如果真 (欲解密的文本 = “”)
    返回 (“”)
.如果真结束
.如果真 (用于解密的密码 = “”)
    返回 (欲解密的文本)
.如果真结束
返回 (到文本 (RC4加解密_E4A (十六进制文本到字节集 (欲解密的文本), 用于解密的密码)))