access数据库查询添加编辑删除等源码

陌路 2019-10-12 18:04:33
导读现在做到把数据库刚刚建立的进度,把这个简单的例子贡献给不懂数据库操作的新手学习一下,这个系系流向主要是用于反应工地安装进度的一个软件。

access数据库查询添加编辑删除等源码

.如果真 (编辑框_查找工程名称.内容 = “”)
信息框 (“输入要搜索的内容”, 48, “提示”)
返回 ()
.如果真结束
.判断开始 (选择框_记录搜索_模糊搜索.选中 = 假)
Sql语句 = “select * from GCXX where GCMC='” + 编辑框_查找工程名称.内容 + “'”
.默认
Sql语句 = “select * from GCXX where GCMC like ” + “'%” + 编辑框_查找工程名称.内容 + “%';”
.判断结束
超级列表框.全部删除 ()
操作记录集.打开 (Sql语句, 数据库连接, 真)
.如果真 (操作记录集.记录数量 () = 0)
信息框 (“数据库中没有该名称的记录!”, 48, “提示”)
操作记录集.关闭 ()
返回 ()
.如果真结束
.计次循环首 (操作记录集.记录数量 (), i)
工程编号 = 操作记录集.读入字段名记录 (“GCBH”).取文本 ()
工程名称 = 操作记录集.读入字段名记录 (“GCMC”).取文本 ()
索引 = 超级列表框.插入表项 (, , , , , )
超级列表框.置标题 (索引, 0, 工程编号)
超级列表框.置标题 (索引, 1, 工程名称)
操作记录集.到下一条 ()
处理事件 ()
.计次循环尾 ()
操作记录集.关闭 ()