Ex_DirectUI自绘的会计从业题库学习软件源码

陌路 2019-10-09 13:00:08
导读Ex_DirectUI自绘会计从业题库是去年考会计从业的时候写的,软件基本完善,题库数据库都在文件夹里,还有部分功能你们自己添加吧。

Ex_DirectUI自绘的会计从业题库学习软件源码

.子程序 _绘制表项背景_列表框, 整数型, 公开, 默认返回0,自己绘制则返回非0
.参数 图形指针, 整数型
.参数 表项矩形, RectF
.参数 表项状态, 整数型, , #状态_
.参数 表项索引, 整数型
.局部变量 color, 整数型

.如果真 (表项状态 = #状态_正常)
color = RGB2ARGB (#白色)
.如果真结束
.如果真 (表项状态 = #状态_点燃)
color = RGB2ARGB (#灰色, 100)
.如果真结束
.如果真 (表项状态 = #状态_选择)
color = RGB2ARGB (#深灰)
.如果真结束

图形_填充_矩形 (图形指针, 表项矩形, color)
返回 (1)

.子程序 _计算尺寸_列表框, , 公开, 组件初始化时设置会重载该函数.
.参数 表头高度, 整数型, 参考, 修改本参数将影响表头高度.仅 #列表类型_报表 有效.
.参数 表项宽度, 整数型, 参考, 修改本参数将影响表项宽度.仅 #列表类型_平铺列表 有效.
.参数 表项高度, 整数型, 参考, 修改本参数将影响表项高度

表头高度 = 30
表项高度 = 30

.子程序 _绘制表项_列表框, 整数型, 公开, 默认返回0,自己绘制则返回非0
.参数 图形指针, 整数型
.参数 表项矩形, RectF
.参数 表项状态, 整数型, , #状态_
.参数 表项索引, 整数型
.参数 列索引, 整数型
.参数 图标矩形, RectF, 参考, 修改本参数将影响图标所在矩形
.参数 文本矩形, RectF, 参考, 修改本参数将影响文本所在矩形

图形_画直线 (图形指针, RGB2ARGB (12961221), 表项矩形.left, 表项矩形.top + 表项矩形.Height - 1, 表项矩形.left + 表项矩形.Width - 1, 表项矩形.top + 表项矩形.Height - 1) ' 直线 _画矩形下面
' 图形_画直线 (图形指针, RGB2ARGB (#红褐), 取列表宽 (列索引), 表项矩形.top, 取列表宽 (列索引), 表项矩形.top + 表项矩形.Height) ' 竖线_等列宽
返回 (0)