易语言Acc数据导出为Excel例程源码

陌路 2019-10-09 12:53:44
导读易语言Acc数据导出为Excel例程源码,由于EXCEL表格的列标号是字母A到Z而不是数字,所以得把字母放入一个变量,用变量[数字]来得到相应的列标号字母。

易语言Acc数据导出为Excel例程源码

通用对话框.标题 = “保存Excel文件”
通用对话框.默认文件后缀 = “.xls”
通用对话框.过滤器 = “Excel文件|*.xls”
通用对话框.初始目录 = 取当前目录 ()
通用对话框.文件名 = “导出零件特制件信息” + 到文本 (取现行时间 ()) + “.xls”
.如果 (通用对话框.打开 () = 真) ' 先判断用户是否真的执行了导出命令,如果出现保存提示框后,用户选择了取消,那么,下面的代码将不会执行,就可以避免取消时已经打开的EXCEL程序提示要不要保存的问题
字母 [1] = “A”
加入成员 (字母, “B”)
加入成员 (字母, “C”)
加入成员 (字母, “D”)
加入成员 (字母, “E”)
加入成员 (字母, “F”)
加入成员 (字母, “G”)
加入成员 (字母, “H”)
加入成员 (字母, “I”)
加入成员 (字母, “J”)
加入成员 (字母, “K”)
加入成员 (字母, “L”)
加入成员 (字母, “M”)
行 = 零件特制件超级列表框.取表项数 () ' 这个行数将来用作循环导出时记录的行数,也就是记录数,导出电子表格需要行循环和列循环,是嵌套的
列 = 零件特制件超级列表框.取列数 ()
.如果真 (取反 (零件特制件超级列表框.取表项数 () > 0)) ' 判断超级列表框中有没表项,如果没有,就是说没有查询出记录,也就不必要导出了
信息框 (“查询结果列表中没有信息!请先定义条件查询出结果再进行导出.”, 0, )
返回 ()
.如果真结束
.如果 (Excel程序1.创建 ()) ' 如果创建失败,证明客户的电脑上没有安装EXCEL,导出是不能成功的,所以判断一下,没有就取消

.否则
信息框 (“您的计算机没有安装EXCEL2000电子表格软件,请安装EXCEL后再使用此功能!”, 0, )
返回 ()
.如果结束
Excel程序1.显示 = 真 ' 通常导出数据时不要显示EXCEL程序,但在编程调试的时候,还是打开为好,看看实际效果,编译时再关掉.要是能不打开EXCEL程序而实现导出就好了,很慢的,
Excel工作簿1.置程序 (Excel程序1)
Excel工作簿1.表格序号 = 1
Excel工作簿1.表格名 = “导出图书信息”
.计次循环首 (列, 列计次) ' 这个循环把数据库里的所有字段名读出并写入到EXCEL程序的第二行里面,当作表格的列标题
Excel工作簿1.首单元格 = 字母 [列计次] + “1”
Excel工作簿1.尾单元格 = 字母 [列计次] + “1” ' 当循环第一次时,字母[列计次]就是字母[1],它的值是A,加字符2后是A2,A2就是EXCEL表格中的第二行第一列,第一行合并了,写入了一个标题
Excel工作簿1.内容 = 零件特制件超级列表框.取列标题 (列计次 - 1)
.计次循环尾 ()
.计次循环首 (行, 行计次)
.计次循环首 (列, 列计次)
Excel工作簿1.首单元格 = 字母 [列计次] + 到文本 (行计次 + 1)
Excel工作簿1.尾单元格 = 字母 [列计次] + 到文本 (行计次 + 1)
Excel工作簿1.内容 = 零件特制件超级列表框.取标题 (行计次 - 1, 列计次 - 1)
.计次循环尾 ()
.计次循环尾 ()
Excel工作簿1.自动调整 ()
Excel工作簿1.保存 (通用对话框.文件名)
信息框 (“导出文件成功!” + #换行符 + “该文件保存在” + 取当前目录 () + “下,” + “文件名为:” + 通用对话框.文件名, 0, , )
Excel工作簿1.关闭 ()
Excel程序1.退出 ()
.否则
信息框 (“由于用户取消,本次导出没有成功!”, 0, )
Excel工作簿1.关闭 ()
Excel程序1.退出 ()
返回 ()