游戏脚本源码附自动登陆做任务写法

陌路 2019-10-09 12:48:24
导读发现好多易友看不懂代码或者不知道是什么东西,抽空写了个简单的例子出来,如果还有什么不明白的地方我会给你解答但不会给你写代码。

游戏脚本源码附自动登陆做任务写法

.子程序 登录游戏, 文本型

.判断开始 (按钮1.禁止) ' 在这里判断是否登录了游戏
返回 (“进入游戏”) ' 登录成功之后执行 进入游戏 函数
.默认
' 未进入游戏 在这里写登录游戏的代码 执行代码之后 返回 登录游戏 即继续执行这个函数来进行判断
返回 (“登录游戏”) ' 未登录游戏 在这里写登录游戏的代码
.判断结束


.子程序 进入游戏, 文本型

.判断开始 (按钮2.禁止) ' 在这里判断是否进入了游戏
返回 (“移动到传送师”) ' 进入游戏成功之后执行 移动到传送师 函数
.默认
' 未进入游戏 在这里写进入游戏的代码 执行代码之后 返回 进入游戏 即继续执行这个函数来进行判断
返回 (“进入游戏”)
.判断结束


.子程序 移动到传送师, 文本型

.判断开始 (按钮3.禁止) ' 在这里判断 人物是否到达 传送师 旁边 到达之后执行函数 传送到其它地图
返回 (“传送到其它地图”)
.默认
' 未到达传送师旁边 在这里写 移动到传送师 的代码 执行代码之后 返回 移动到传送师 即继续执行这个函数来进行判断
返回 (“移动到传送师”)
.判断结束


.子程序 传送到其它地图, 文本型

.判断开始 (按钮4.禁止) ' 在这里判断 是否传送到了其它地图 传送了之后执行函数 开始工作
返回 (“开始工作”)
.默认
' 未传送到其它地图 在这里写 传送到其它地图 的代码 执行代码之后 返回 传送到其它地图 即继续执行这个函数来进行判断
返回 (“传送到其它地图”)
.判断结束


.子程序 开始工作, 文本型

.判断开始 (按钮4.禁止) ' 在这里判断是否到达了指定地图 到达之后 执行你要做的工作
' 在这里写一些 打怪 或 做任务 的代码 之后返回 开始工作 这样即无限调用 开始工作
返回 (“开始工作”)
.默认
' 未到达指定地图 返回 任务完成 这里是执行失败了
返回 (“任务完成”)