入门级ADO类源码通杀win平台数据库

陌路 2019-10-09 12:39:00
导读一种程序对象,用于表示用户数据库中的数据结构和所包含的数据,在 Microsoft Visual Basic 编辑器中,可以使用ADO对象以及ADO的附加组件称为Microsoft ADO Extensions for DLL and Security(ADOX)来创建或修改表和查询、检验数据库、或者访问外部数据源。还可在代码中使用ADO来操作数据库中的数据。

入门级ADO类源码通杀win平台数据库

记录操作为何频频出错?多线程下程序为何总是崩溃?数据丢失究竟是何缘由?BUG一出再出的背后到底隐藏着什么?这一切背后是人性的扭曲还是道德的沦丧?是智商的爆发还是菜鸟的无奈?史诗级灾难片《从0到1》

前面开源了不少帖子,基本上都是力气活含金量不高,但是这个模块绝对的高精尖技术,在易语言里面属于高级教程了。我只能说这模块源码不是一般人能驾驭的,能够精通此模块数据库方面基本通杀了,目前使用此模块的易友已经破百了,模块还在持续更新ing。我一般不开源,开源就来点重量级的。

.子程序 保存到Excel, 逻辑型, 公开, 将指定库的数据表导出保存到xls文件且需要office支持,成功返回真,感谢易友反馈的参数空的BUG
.参数 参库索引, 数据库类型
.参数 参Excel路径, 文本型, , .xls为后缀,导出的文件路径,如果存在重名则覆盖
.参数 参数据表名, 文本型, , 导出的数据表名
.局部变量 SQL语句, 文本型
.如果真 (文件是否存在 (参Excel路径))
删除文件 (参Excel路径)
.如果真结束
SQL语句 = “Select * Into [Excel 8.0;database=%db].%tb From %tb”
SQL语句 = 子文本替换 (SQL语句, “%db”, 参Excel路径, , , 真)
SQL语句 = 子文本替换 (SQL语句, “%tb”, 参数据表名, , 2, 真)
打开 (参库索引, SQL语句, 真) ' 如果返回假,可尝试修改游标位置
关闭 ()
返回 (文件是否存在 (参Excel路径))