视频批量替换文件名工具

易语言 2021-09-17 17:54:54

视频批量替换文件名工具

视频批量替换文件名工具开源。

.判断开始 (编辑框_文件夹路径.内容 = “”)
信息框 (“请选择要替换的文件夹!”, 0, , )
返回 ()
.判断 (编辑框_欲替换的文本 = “”)
信息框 (“请输入欲替换的内容.”, 0, , )
返回 ()
.默认

.判断结束
局_文件路径 = 编辑框_文件夹路径.内容 + “*” + 组合框_后缀.取项目文本 (组合框_后缀.现行选中项)
局_文件名 = 寻找文件 (局_文件路径, 1 + 2 + 4 + 16 + 32)
.判断循环首 (局_文件名 ≠ “”)
加入成员 (局_文件数组, 编辑框_文件夹路径.内容 + “\” + 局_文件名)
.如果真 (寻找文本 (局_文件名, 编辑框_欲替换的文本.内容, , 假) ≠ -1)
文件_改名 (编辑框_文件夹路径.内容 + 局_文件名, 编辑框_文件夹路径.内容 + 子文本替换 (局_文件名, 编辑框_欲替换的文本.内容, 编辑框_要替换的文本.内容, , 1, 真))
.如果真结束
局_文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)
.判断循环尾 ()


下一篇 返回列表