access数据库取表名和某表下字段名的两个子程序

易语言 2021-08-02 13:06:31

.子程序 取mdb数据库某表字段名
.参数 数据库, 数据库连接
.参数 记录集, 记录集
.参数 表名, 文本型
.参数 字段名, 文本型, 数组, 文本数组,存储返回的字段名
.局部变量 a, 整数型

清除数组 (字段名)
记录集.置连接 (数据库)
记录集.打开 (“select * from ” + 表名, #SQL语句, )
.计次循环首 (记录集.字段数量, a)
加入成员 (字段名, 记录集.取字段名 (a - 1))
记录集.到下一条 ()
.计次循环尾 ()
记录集.关闭 ()